There was an error in this gadget

+1

Saturday, April 26, 2008

Things to do on your new Ubuntu 8.04 Hard Heron Installation

Ubuntu 8.04 was released a few days back and like the previous releases of Ubuntu,Ubuntu 8.04 does not include a number of essential codecs, applications etc because of number of licensing restrictions and also the limitation of accommodating more and more applications on a single CD. Though undoubtedly Ubuntu 8.04 is one of the most user friendly release of Ubuntu with inclusion of Firefox 3 (though it is beta version but still is way better than the current stable version of Firefox) ,inclusion of bit-torrent client , out of box support for playing youtube videos etc . Still someone trying to make the jump from Windows to Ubuntu might be interested in installing the following applications and codecs too .

(Note : This article is updated version of the article i had written earlier "Creating your Ultimate Ubuntu 7.10 Desktop " )

1. Putting your repositories in order

Now many applications need additional repositories to be installed or some to be enabled in Synaptic package manager so before trying out steps given below ensure that repositories in order.

Launch Synaptic Package Manager (System -> Administration -> Synaptic Package Manager ) , then in Synaptic package manager go to (Settings -> Repositories ) you will find window like this .



Ensure that all the check boxes are marked leaving source code(if you want to you can enable this also but you are not going to need this unless you are software developer) the dialog box should look like this .

Now for installing codecs and some applications we need mediubuntu repository too which could be added by issuing the following command in the terminal window (Applications -> Accessories -> Terminal ):

sudo wget http://www.medibuntu.org/sources.list.d/hardy.list -O /etc/apt/sources.list.d/medibuntu.list
and

wget -q http://packages.medibuntu.org/medibuntu-key.gpg -O- | sudo apt-key add - && sudo apt-get update

Uf you have followed the above steps properly your repositories should be in order for following the steps below .

2. Installing Multimedia codecs for GStreamer

The first thing anyone who wants to use Ubuntu as a replacement to their windows operating system would like to do is install support for all kind of audio/video multimedia codecs . Ubuntu does not come installed with support for major audio/video formats because of licensing issue and other issues . To install support for audio/video codecs type in the following command in the terminal window : -

sudo apt-get install faad gstreamer0.10-ffmpeg gstreamer0.10-plugins-bad gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-ugly gstreamer0.10-plugins-ugly-multiverse gstreamer0.10-pitfdll liblame0
or you could better still install ubuntu-restricted package with the following command :

sudo apt-get install ubuntu-restricted-extras

This would enable most of the popularly used codecs in the Totem Movie player which uses the GStreamer framework to play audio/video files.

If you want to use a different media player and framework you might try installing MPlayer or VLC (depending on which you prefer ) instructions on installing them are listed below .

Installing additional codecs :

*This step requires mediubuntu repositories

w32codecs contain a number of windows DLL files that are used by a number of media players including mplayer and xine to play various media files . To install this issue the following command in the terminal widnow :

sudo apt-get install w32codecs

Installing build-essential Package

Even if you don't intend to use Ubuntu for making applications , still a lot of open source applications don't provide binary and you have to compile them from their source code . Now Ubuntu for some strange reason does not come preloaded with GNU C++ compiler and other tools necessary for compiling applications so you have to install this package separately to install this package issue the following command in the terminal window :

sudo apt-get install build-essential


3. Avant Window Navigator

IMPORTANT : - To use AWN Compiz-Fusion should be up and running as mentioned in the step above

Avant Windows Navigator is cool little tool that allows you to have a cute looking dock at the bottom of the screen . Even though AWN is still very buggy, still because it is so feature rich and cool looking you could install it .


To install AWN you need to add extra repositories, now adding any additional repository carries certain amount of risk of screwing up your system so follow these step at your own risk :

To add repository :

echo "deb http://ppa.launchpad.net/awn-testing/ubuntu hardy main" | sudo tee -a /etc/apt/sources.list

and

echo "deb-src http://ppa.launchpad.net/awn-testing/ubuntu hardy main" | sudo tee -a /etc/apt/sources.list

After issuing above command type the following command to update your repositories :

sudo apt-get update
anf finally to install AWN issue the following command in the terminal window :

sudo apt-get install awn-manager-trunk awn-extras-applets-trunk
Now after completing above mentioned steps AWN should be properly installed , To Launch AWN go to (Applications -> Accessories -> Avant Window Navigator )

Now you could customize AWN by choosing to add more applets , configuring 3D effects for AWN etc by going to AWN Manager (
System -> Preferences -> Awn Manager )




Three ScreenShots of AWN Manager
Though the theme which AWN comes with preinstalled is also good , you might like to try this it's cool and very Mac like

http://rapidshare.com/files/71511920/Transparent.tgz.html

you could install this theme through AWN Manager .

This is how my AWN Dock looks(with the above theme installed) like : -


AWN-DOCK



4. Installing MPlayer with all codecs and dvd playing support
*This step requires Medibuntu repositories

MPlayer is one of the most popular media player available on linux , it supports playing all the major audio/video file formats . With w32codecs and libdvdcss2 it plays all the major audio/video format,however w32codecs has dll files from windows operating system hence its not available on the ubuntu official repositories and needs to be downloaded from the mediubuntu repositories.

To install MPlayer with all codecs type in the following command in the terminal window : -
sudo apt-get install mplayer

and
sudo apt-get install w32codecs
After completing above steps you could launch MPlayer by typing in gmplayer in the terminal window or from (Application -> Sound & Video -> MPlayer Movie Player )

Note : Installing Support for playing DVD's (taken from ubuntuforum post )

Issue the following command in the Terminal window :

sudo apt-get install libdvdcss2 libdvdread3 libdvdnav4 build-essential debhelper fakeroot

then:

sudo /usr/share/doc/libdvdread3/install-css.sh

or if you get an error with that command:

sudo /usr/share/doc/libdvdread3/examples/install-css.sh

5. RealPlayer

Realplayer is one of the most popular cross platform media player available on Windows,Linux , Mac OS and a number of other platform . RealPlayer plays popular .rm ,rmvb,.mp3 and other media formats.

To install RealPlayer first download RealPlayer10GOLD.bin file from the following website assuming you have downloaded it to your home directory .

After downloading the file go to the directory where you have downloaded the file in terminal window and type

After installation is over type

¨chmod +x RealPlayer10GOLD.bin¨

and

¨sudo ./RealPlayer10GOLD.bin¨

for installation to begin . Follow the instructions as presented to complete installation .

After installation is over you can launch Real Player from (Application -> Sound & Video -> Real Player 10 ).

Real Player for Linux


Note : It has been reported that Real player is not working properly :( i would update these instruction once i figure out solution to the problem .

6. Flash and Java Support

Both Macromedia Flash and JRE are an important part of internet experience almost all the websites use either of the two technology to add extra functionality to the web page . By default Ubuntu does not come preinstalled with support for these two , however they can be installed quite easily by typing in the following command in the terminal window .

To install flash type in the following command in the terminal window this command is going to download a script that would further download the files needed for installing flash-support and install it .

To install Adobe version of flashplayer (The official one ) :

Note : As pointed out by one of the readers there might be some kind of bug with the flashplayer so for the time being you might not like to install the the offical flash plugin , it would be better if you install the Free Opensource gnash player instead (instructions given below)

sudo apt-get install flashplugin-nonfree libflashsupport
or
To install Open Source Flash Player (though some sites may not render properly or not render at all !!! )

sudo apt-get install mozilla-plugin-gnash

To install Sun Java Runtime Environment and plugin :
sudo apt-get install sun-java6-fonts sun-java6-jre sun-java6-plugin

7. Firefox 2 Anyone ???

Ubuntu 8.04 comes installed with Firefox 3 Beta 5, now even though Firefox 3 beta 5 even after being beta version is very usable and is a lot better than Firefox 2 in terms of features. Still if you are facing problems (or you just want to use plugins that have not been designed for newer version of Firefox ) you could install Firefox 2 along with Firefox 3 Beta 5 by issuing the following command in the terminal window :

sudo apt-get install firefox-2
after issuing the above command go to (Applications -> Internet -> Firefox 2 Web Browser ) to launch Firefox 2 .

Firefox 3 Beta 5 and Firefox 2 installed simultaneously .


8. installing Microsoft fonts package

Even if you hate Microsoft Windows still majority of desktop computers around the world run some or other variant of Windows . Now sharing documents , web pages across Linux and Windows is bit difficult as document created in Windows do not render properly/or look as they did in Windows because the fonts which were present in windows are not available in Linux . Now even though Microsoft has released these fonts freely but still because of licensing issue most of the Linux distributions do not ship these fonts by default and you have to install them separately.

Here below we discuss how to install the following Microsoft fonts on your Ubuntu Desktop :

  • Andale Mono
  • Arial Black
  • Arial (Bold, Italic, Bold Italic)
  • Comic Sans MS (Bold)
  • Courier New (Bold, Italic, Bold Italic)
  • Georgia (Bold, Italic, Bold Italic)
  • Impact
  • Times New Roman (Bold, Italic, Bold Italic)
  • Trebuchet (Bold, Italic, Bold Italic)
  • Verdana (Bold, Italic, Bold Italic)
  • Webdings
To install these fonts issue the following command in the terminal window (Applications -> Accessories -> Terminal ) { Assuming you have your repositories in order }

sudo apt-get install msttcorefonts
After issuing the above command , apt-get will download few files and then you will be greeted with the following screen :

After clicking the Ok button , you will find the following screen showing the fonts are being downloaded .
After this process is over issue the following command in the terminal window :

sudo fc-cache
if the above steps worked without any problem the font should be installed properly on your system .


9. Adobe Reader

On Ubuntu/Linux a number of good pdf reader exist that are quite functional and less resource hungry as compared to Adobe Reader , However if you still want to install Adobe Reader 7.0 you can either download package from adobe website or type the following command in the terminal window .

However note ,
the following command would only work if Medibuntu repositories are configured properly so be sure you have installed it correctly as described in the beginning of article .


sudo apt-get install acroread


Some Misc Applications you might be interested in :

10. Downloader For X

Downloader for X is a nice download manager that allows downloading files from Internet , pausing them and downloading them later . It also supports splitting file into number of segments so that files could be downloaded quickly . However one thing that i didn't like about is it's interface is somewhat difficult as compared to some of the download manager available on Windows.

Anyways to install " Downloader for X " type the following command in the terminal window.

¨sudo aptitude install d4x "


After installation is over launch ¨Downloader for X¨ by typing ¨d4x¨ in the terminal window , or by going to (Applications-> Internet -> Downloader for X )


This is how Downloader for X looks

11. aMule

aMule is alternative to popular eMule program on windows platform , amule supports/works with eDonkey2000 Network or Kadnetwork and allows P2P sharing of files . aMule is available on number of platforms , Current supported systems include Linux, Mac OS X, FreeBSD, NetBSD, OpenBSD, Windows and Solaris.

To install aMule type the following command in the terminal window : -

sudo aptitude install amule
After completing above step launch aMule from (Application -> Internet -> aMule )

12. . aMSN

aMSN is a MSN Messenger clone for Linux operating system , it tries to emulate look and feel of MSN messenger as close as possible allowing linux newbies to use aMSN easily .

aMSN has features not present in MSN Messenger. Users can set alarms, are able to see others who have removed them from their contact list, and are able to open many profiles at once. It is also very customizable, with extensions and themes available at the main site.

To install aMSN type the following command in the terminal window : -

sudo apt-get install amsn
and after completing installation launch aMSN from (Applications -> Internet -> aMSN )

13.
Installing Linux DC++ Client

DC++ is a popuar tool used for p2p file sharing and is especially popular in college campuses , to install dc++ for linux follow the following instructions .

Type the following command in the terminal window: -

sudo apt-get install linuxdcpp
And after completing above step launch dcpp from (Applications -> Internet -> DC++)
Linux Client of popular DC++ Application


14.
CheckGmail

CheckGmail is a nifty little gadget/widget that sits in your taskbar and once configured automatically informs you whenever you receive new email in your GMail Inbox .

To install CheckGmail type in the following command :

sudo apt-get install checkgmail


and after installation is over you can launch it from (Applications -> Internet -> CheckGmail )

15.Installing VLC Player : -

VLC Player is another of popular video player available under Linux . It is released under GNU General Public license and is available for different platform including Windows,Linux,BeOS,Mac OS X etc. VLC player is based upon free open source libraries like libdvdcss,FFMpeg for decoding various video formats.One Important feature of VLC Player is it's ability to play files over NetWork Protocols. The Frontend of VLC player is created using wxWidgets toolkit and it's appearance can be changed by using different skins. One Popular feature of VLC Player is it's ability to play files that are incomplete/broken or partially downloaded , making it useful for previewing file while downloading on file-sharing networks.

To install VLC Player type the following command in the terminal window : -

sudo apt-get install vlc
After completing above step launch vlc player from (Applications -> Sound and Video -> VLC media player )

16. Audacity

Audacity is open source cross platform software for recording and editing sound files . The Graphical interface of Audacity was created using wxWidgets library .

some of Audacity's features include:
  • Importing and exporting WAV, AIFF, MP3 (via the LAME MP3 Encoder, downloaded separately), Ogg Vorbis, and other file formats
  • Recording and playing sounds
  • Editing via Cut, Copy, Paste (with unlimited Undo)
  • Multi-track mixing
  • Digital effects and effect plug-ins. Additional effects can be written with Nyquist
  • Amplitude envelope editing
  • Noise removal
  • Support for multichannel modes with sampling rates up to 100 kHz with 24 bits per sample
  • The ability to make precise adjustments to the audio's speed, while maintaining pitch, in order to synchronise it with video, run for the right length of time, etc.
  • Large array of plug-ins available

To install Audacity type the following command in the terminal window : -

sudo apt-get install audacity
After completing install launch audacity from (Applications-> Sound & Video -> Audacity )

Audacity Interface



Article Written by : Ambuj Varshney (blogambuj@gmail.com)
For Desktop on Linux Blog , http://linuxondesktop.blogspot.com
(C) 2008 , Ambuj Varshney

23 comments:

Matt said...

Nice post! I plan on doing most of those things as soon as I have time. I think I might have read that gnome now has it's own basic compositing. I don't know how to enable it but I think you can use it run awn. I can't wait to try that out because my computer is a little bit too slow to run compiz smoothly.

Clouseau said...

FIREFOX 3 IS THE DAMN DUMBEST THING ANYONE COULD DO

- do you use mff because tags? no
- for its speed? hahahaha! no
- because the site are optimized for internet explorer? no
- for its ease of use? no
- for its flexibility? no
- because its lightweight? hahahaha! no
- for its safety? no
- because it preserves your privacy with password protected profile support (existing and disabled)? no

NO: u use mff because you are hooked by extensions
90% of key extensions dont work in 3
when upgrading 3 import 2's configuration and destroy it definitively: no profile backup? no party!

i spent a whole day to re-configure mff 2 with all my extensions and configs...

we waited 6 months to have openoffice updated to stable release, and they force you to use a stupid beta with almost no extra features?

c'mon, ubuntu is only the less bad distro for the non programmer and no debian guru

mepis is far away to be ready, but is much better, much faster, much nicer, MUCH... it's a problem of money: behind ubuntu there are zillions of dollars, and NO community, but a military organization...

Anonymous said...

On Step 6 you recommend install LibFlashsupport. I would remove that for now, see bug # 192888 for moredetails

Travis said...

clouseau:

if you don't like firefox don't use it. Though honestly, I'd rather use firefox than Internet explorer anyday.

Maybe mepis is better for you, maybe it's better for others, but that's why there are different Distributions.

Other than that, great post!

Matthew Holloway said...

I don't necessarily agree with it but as I understand it the reason they chose Firefox 3 beta rather than Firefox 2 is because this is an LTS release and over that time Firefox 3 will be support by Mozilla whereas Firefox 2 will probably be ended. This is just what I read on Slashdot though, so don't take it as necessarily correct.

I imagine that in a few weeks the main extensions will be running under FF3. In the meantime you can install FF2.

Tim Broder said...

Nice List. I had to uninstall tracker though, it was causing most of my programs to hang ever other min or so. Also, KcheckGmail imo is prettier looking then checkgmail

Anonymous said...

It's great article man very very helpfull
people like you made ubuntu what it is today,
Thank you so much and keep up the good work :-)

Regards
Said

Anonymous said...

As for the extensions, there is a tool called "Nightly Tester Tools" which helps in allowing some extensions to work until they are "officially" supported. It's what I used and it worked well.

Pace

James said...

Real player 11 is what you can download and it fails to install. When I type ./RealPlayer11 it says:

Extracting files for Helix installation....sh: /home/user/DL/Codecs: not found
tar: This does not look like a tar archive
tar: Error exit delayed from previous errors....
Also I upgraded my 7.10 using the built-in upgrade with the package manager. Did ok but many of the codecs don't work can't play dvd's and I have tried to reinstall them but they say they are already there. Had to manually remove firefox 3 to get firefox2 on there. The only way to do it was manually place firefox 2 by hand. If I tried using synaptic it would still come up as firefox 3 regardless of if I specified the firefox 2 or not even after I had removed firefox 3. Firefox 3 at this point is horrible and loaded with problems. THey also default to the most rediculous encryption certificate policy blocking all non top tier certificate makers and all user signed thus forcing everyone to pay for the ridculously expensive encryption certificates which in practice provide no real improvement in protection.

Have yet to try a fresh 8.04 install. Very disgusted with the upgraded system.
--James

Jeff said...

Ubuntu continues to put out the gFTP with sftp secure encrypted ftp removed from the distro. So you have to go into synaptic and lock their gftp and then go download gftp source and compile it to get the full functioning gftp. I'm really sick of this... no you can't just stick in the deb package for gftp as it has cross over dependencies (one package needs another pakage that needs it) and in Hardy they have removed the ability to not check for dependencies form Kpackage or any other method that I can find. But thankfully gftp compiled works great with sftp. Hence no reason they are removing it other than to just cause massive problems.

Anonymous said...

This is one of the best guides I've ever seen so far! Thank you! Very helpful! Keep up the good work!!

Anonymous said...

As Pace said (4 posts back) the "Nightly Tester Tools" allows you to maek Firefox-2 extensions declare themselves to be "compatible". At which point, they might actually BE compatible -- or they might not ;). Be sure to get the "full" version of NTT, not the "light" version.

The following are all working great here, although I'm not an Ubuntu guy and I'm using a much newer "Nightly" Build of Firefox than your 3.0b5 package:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008050520 Minefield/3.0pre ID:2008050520

Adblock Plus 0.7.5.4
Adblock Plus: Element Hiding Helper 1.0.4
AutoFormer 0.4
CLEO 3.3.1
ColorfulTabs 3.0
Connect to address 1.1.7
Console² 0.3.9.1
Download Statusbar 0.9.6.1
Extension Developer 0.3.0.20060726
Extension Manager Extended 2.6.3.2
FEBE 5.3.1
Firefly 0.3.3
Flashblock 1.5.5
Forecastfox 0.9.6
Form Saver 0.7
Greasemonkey 0.7.20080121.0
Html Validator 0.8.4.0
JavaScript Debugger 0.9.87.3
Leak Monitor 0.4.2 [DISABLED]
Linkification 1.3.3
Mozilla Quality Extension 0.1.5
MR Tech Local Install 5.3.2.6
Nightly Tester Tools 2.0.2
Nuke Anything Enhanced 0.68.1
Platypus 0.66
QuickJava 0.4.2.1
Remove It Permanently 1.0.6.3
RSS Validator 0.3.2
Screen grab! 0.93
Searchbar Autosizer 1.3.8
Stop-or-Reload Button 0.2.2
Tab Mix Plus 0.3.6.1.080416
Text Complete 0.9.9.3
Tinderstatus 0.2.8
Toolbar Buttons 0.5.0.4
User Agent Switcher 0.6.11
View Dependencies 0.3.3.0
Web Developer 1.1.5
YesScript 1.3

(But I'm not sure that FEBE/CLEO actually work, I've been creating tarfiles to do my backups. Haven't actually touched FEBE in months, and I won't be building a FF3 CleoPack of this stuff until after RC1 is released.)

-rickst29

Marvin said...

Nice Tango theme for Downloader For X can be downloaded from
http://www.gnome-look.org/content/show.php?content=38304

Anonymous said...

If your fav extension does not work with FF3 then get nighty tester tools while logged into mozilla adds.

sybillinux said...

firefox has lost the chance to become the leader...

anyway i say exactly what i want on what i want, and i use what is there, so please all, stop bogging me with sentences as
"the door is over there", "you don't like, you can't use it..." and so on...

to stay on focus:

nightly tester is the first step to have your mff3 tuned, it can't solve most of so called incompatibility

install nightly tester

restart

insert the new property boolean extensions.checkCompatibility and set it false in about:config

install user agent switcher

disable nightly tester

restart

when you are on the add-ons site, select internet explorer as user agent

refresh

proceed light-speed wherever you want and install anything at your own risk: it will work on a 99% basis (i could give warranty, but i do not)

restart and enjoy to have fucked mff devs

(you can repeat all the steps any times you wish)

Juraj said...

Thanks a bunch. Bookmarked it!

Anonymous said...

Nice work Done !!!

Mikey said...

great article

Brown said...

Nice, I have been using ubuntu for a while and still I never used most of these programs, So once again thank you

Anonymous said...

For Real player 11 type this code in and it should work for unbuntu 8.04

sudo apt-get install realplayer
killall gnome-panel

Anonymous said...

just wanted to say thanks...don't normally reply but I have been working on this for 3 days straight now, googling solutions and you were the only one who actually knew what you were talking about!

hello said...

I have just read through this page and though I'm sure all of these steps would improve my use of Ubuntu, this is far too complicated for the average guy. For example, how do you follow the steps outlined and paste in the codes without having two computers up and running?
Patrick
PS Even posting this comment was over complicated.

hello said...

Just read through this posting and it is far too complicated for the average gut. Hell, even posting this comment was far too complicated (I had to post it twice). Patrick

Post a Comment