There was an error in this gadget

+1

Tuesday, May 13, 2008

Weather Information on your Ubuntu 8.04 desktop with Weatherbug

Weatherbug operates one of the largest weather network in the world providing information like local temperatures, wind speed, radar, and forecasts etc .Weatherbug widgets were already available on the Windows and Mac OS platform and now they have released their widgets for the Linux platform also providing weather information through user friendly widgets to people using Linux.



To install weatherbug issue the following command in the terminal window (Applications -> Accessories -> Terminal )


Note : Weatherbug needs Java Runtime Environment to be installed since it is a java application , also i have found that weatherbug for some reason does not work with open source gcj instead it needs Sun JRE . Inorder to run weatherbug you would have to install Sun JRE which could be done by typing the following command in the terminal window :



sudo apt-get install sun-java5-jre libswt3.2-gtk-java

To install weatherbug issue the following command in the terminal window :
wget http://wdownload.weatherbug.com/linux/weatherbug-1.0-1.deb


and

sudo dpkg -i weatherbug-1.0-1.deb



After completing the installation you can launch weatherbug from (Applications -> Accessories -> Weatherbug )

Weatherbug Widget
This is how my desktop looks with Weatherbug widget

Article Written by : Ambuj Varshney (blogambuj@gmail.com)
For Desktop on Linux Blog , http://linuxondesktop.blogspot.com
(C) 2008 , Ambuj Varshney

2 comments:

Anonymous said...

Being a total newbieto ubuntu, I followed the instructions posted here to install weatherbug and received the following error.Could someone please help me to resolve the missing file?

john@ubuntu:~$ sudo dpkg -i weatherbug-1.0-1.deb
[sudo] password for john:
Selecting previously deselected package weatherbug.
(Reading database ... 120091 files and directories currently installed.)
Unpacking weatherbug (from weatherbug-1.0-1.deb) ...
dpkg: dependency problems prevent configuration of weatherbug:
weatherbug depends on libswt3.2-gtk-java (>= 3.2); however:
Package libswt3.2-gtk-java is not installed.
dpkg: error processing weatherbug (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
weatherbug
john@ubuntu:~$

DDK said...

you have to update after you install java. you either enter sudo apt-get update while in root (su + password or sudo -s + password) or go to update manager and do it thought there. that should fix your problem.

Post a Comment